Revised:
2/15/2023Issue/Symptoms:
Unable to print receipts in Non-Trust Mode
Applies to:
Meevo Receipt Printing
Cause:
A Google Chrome update has taken place, which requires Chrome (Version 94 or higher) and Meevo configuration changes. Please be advised: Future Chrome updates may alter this solution
Solution:
1. In your Chrome browser, enter the following in the web address bar and press enterchrome://settings/help
2. Allow Chrome to update if needed, click "Relaunch" after update
4. Login to Meevo and click on Meevo
5. Click on Register
6. Click on POS Hardware
7. Click Edit in the lower right of window
8. For every receipt printer listed under the "Receipt Printer" tab uncheck the check box "Use Trust Mode", once all printers are unchecked proceed to next step
9. Click Save
Note: Steps 10-14 need to be completed on every computer/workstation that prints receipts
10. Enter the following into the web address bar and press enterchrome://flags/#block-insecure-private-network-requests
11. Find the "Block insecure private network requests" option which should be highlighted as shown below
12. Change the "Block insecure private network requests", which is currently highlighted in yellow, from Default to Disabled
13. The screen should now look like this:
14. Click Relaunch at the bottom of the screen:
15. You should now be able to print receipts in Non-Trust mode
Additional Information:When printing receipts, a Meevo Printer Connection screen will pop up. You can minimize (do not close) this window and navigate back to Meevo.