Not Powering On
Issue/Symptoms:
Receipt Printer doesn’t turn on.
Green power light is off.
Applies to:
Star TSP 650II
Cause:
A discrepancy in the power supply
Solution:
1. Verify the power switch on the left side of the printer is set to on.
2. If it is still not powered on, you will need to trace the black power cable that is plugged into “DC24V“ on the back of the printer.
- Trace this cable to the power adapter or "brick" (pictured below) and confirm that the cord is tight at all connections. Often times, since the power brick is on the floor, it gets stepped on and the cable becomes disconnected. If the connection is tight, the next step is to check the A/C power at the actual outlet.
-One way to test the outlet is by using a phone charger or other device to confirm power.
If this does not resolve your issue please submit a help ticket request to support@cambridgespa.com.