Activation Instructions
Issue/Symptoms:
EMV presents an activation code on the screen and needs to be activated within Meevo
Applies to:
EMVs and computers at location
Cause:
The EMV is not activated within Meevo
Solution:
1. Click "Meevo" under the location name in the top left corner of the screen
2. Click on "Register"
3. Click on "Merchant Accounts"
4. Click "Search"
5. A list of merchant accounts should display, you need to click on the account titled "Main Account"
6. To activate the EMV in Meevo, click on the "Devices" tab on the far left
7. Select the plus ("+") sign to add a New Device
8. You should be prompted with the following screen
9. Make sure the "Is Shared" box is not selected
10. Enter the activation code
Note: Activation codes should start with a "P" followed by numbers
11. Enter the Terminal Name
- The Terminal Name will be based on the Computer it sits next to
-
The naming convention should be as follows:
- EMV_Counter1_XXXX where XXXX is your location number
12. Click "save" and your device should now be activated and added to Meevo
Note: After being activated, your EMV should now read TriPOS on the screen
13. Click on "Walk Me Through" in the top right corner of Meevo
14. Follow the Walk Me Through titled "Activate POS"
15. Once in the POS Stations Tab, verify that the correct EMV is selected for each station under Credit Card Terminal, then save any changes that are made
If this does not resolve your issue please submit a help ticket request to support@cambridgespa.com.