Terminal Does Not Show Display/Cannot Read Display
Issue/Symptoms:
Device is on but nothing is displaying or cannot read display
Applies to:
Meevo – Ingenico iPP320 Credit Card Terminal
Cause:
Contrast Settings Improperly Set
Solution:
1. Reboot the iPP320 Credit Card Terminal by holding the yellow and "#" keys down at the same time for 2–3 seconds
2. When the Copyright screen is displayed, press 2634 and then the green Enter key (You may need to type in the code once more to show the menu)
3. Press F for menu
4. Press 0 for Telium Manager
5. Press 3 for Initialization
6. Press 2 for Hardware
7. Press 3 for Display
8. Press 2 for Contrast
9. Hold the '.' and F3/up arrow buttons together at the same time until ample contrast
10. Hold the yellow and "#" keys down at the same time for 2–3 seconds
If this does not resolve your issue please submit a help ticket request to support@cambridgespa.com.