Terminal is Frozen/Stuck/Hang
Issue/Symptoms:
Credit Card Terminal Stuck on Screen
Applies to:
Meevo – Ingenico iPP320 Credit Card Terminal
Cause:
The device is frozen
Solution:
1. Perform a soft reboot, by holding the yellow button, and the # button simultaneously until you hear a ‘chirp’.
2. Wait about 30 seconds and the display should read TriPOS.
If this does not resolve your issue please submit a help ticket request to support@cambridgespa.com.