Processing FSA/HSA Transactions
Issue/Symptoms:
Need to process FSA/HSA payment
Applies to:
Meevo FSA/HSA card usage
Cause:
MCC Code change to the primary MID required by Visa, a second MID is required to accept FSA/HSA cards for all eligible FSA/HSA transactions
Solution:
Change the assigned drawer in Meevo to use a second MID to process FSA/HSA card transactions.
1. Ensure the Register Tab is NOT open in the Meevo instance
- The Register tab must not be open for the following changes to the POS Hardware to take effect
- To close the Register tab, click on the (X) in the right corner of the tab
i. This is NOT the same action as “closing the drawer”. This action will simply close out of the Register tab
2. Go to Meevo > Register > POS Hardware > POS Hardware tab, or type poshardware in the Convobar
3. Scroll to find the station titled: V-FSA/HSA_####
- #### = your franchised location’s store number
2. CA locations will have more than one V-FSA/HSA POS Station
i. Users should select the station for the computer/pole display they are using for the transaction
ii. V-FSA/HSA_Counter #_####
4. 4. Click the Activate this POS button
a. Clicking the EDIT button is not required
b. Recommendation: Leave the POS Hardware tab open throughout the business day
5. Go to Meevo > Register > Register, or type register in the Convobar to open the Register tab
6. The current assigned drawer will display at the top left corner of the Smart Receipt
7. Select the Edit icon beside the drawer name to open Drawer Manager on the right panel
8. 8. Select your FSA/HSA designated drawer from the Currently Assigned Drawer drop down list
- If the FSA/HSA drawer is closed, follow your franchised location’s process to open the drawer
- The cash amount should be $0.00 as no cash transactions should be processed on this drawer
9. Once selected, this window will close automatically and return user to the Register Screen
a. The user is now assigned to the FSA/HSA drawer and can proceed to process FSA/HSA transactions
10. When the FSA/HSA transaction(s) are complete, follow steps 1-8 again, selecting the POS Station for the workstation and the Main Drawer to toggle to your franchised location’s Main Drawer for non-FSA/HSA card transactions Note: Failure to do so could result in non-FSA/HSA card transactions being processed on the incorrect MID account, potentially leading to large fines.
a. User should select YES when the Please Confirm statement appears
Important Information:
Drawer Open & Close: The new FSA/HSA drawer created to support the second MID will need to be opened and closed following the same process as the franchised location’s Main Drawer.
Recommendation: The FSA/HSA Drawer should remain open during business hours, same as the Main Drawer, to avoid additional delays in completing transactions and reporting issues.