Therapist or Esthetician not showing up for Online Booking
Issue/Symptoms:
Massage Therapist or Esthetician not showing up in Online Booking
Applies to:
Customer Self Scheduling / Online Booking
Cause:
Employee not configured correctly in Meevo or Modality Survey
Solution:
NOTE: All changes made to the employee profile or schedule can take up to 24 hours to reflect on www.massageenvy.com.
For Massage Therapists:
- On the "EMP" screen in Meevo:
- Check to make sure they have the Employee Category “Massage Therapist”.
- Verify they have the Security Role of “Service Provider”.
- Make sure the services they can perform have been enabled.
- Verify that they have their correct schedule set up in the “Schedules” screen.
- Make sure they have a completed modality survey and that has been approved by a manager.
For Estheticians:
-
On the "EMP" screen in Meevo:
- Check to make sure they have the Employee Category “Esthetician”.
- Verify they have the Security Role of “Service Provider”.
-
Make sure the services they can perform have been enabled.
-
Verify that they have at least 1 of the 5 Concern-Focused Facials selected under "Services".
- FACDEFY60 Age-Defying 60 Min Facial and/or FACDEFY90 Age-Defying 90 Min Facial.
- FACBRT60 Brightening 60 Min Facial and/or FACBRT90 Brightening 90 Min Facial.
- FACCALM60 Calming 60 Min Facial and/or FACCALM90 Calming 90 Min Facial.
- FACCLAR60 Clarifying Acne 60 Min Facial and/or FACCLAR90 Clarifying Acne 90 Min Facial.
- FACTONE60 Tone-Balancing 60 Min Facial and/or FACTONE90 Tone-Balancing 90 Min Facial.
- Verify that they have their correct schedule set up in the “Schedules” screen.
-
Make sure they have logged into the iPads at least once.
- Estheticians don’t complete Modality Survey, so logging into the Appointment Notes App will create their Engage profile.
For Stretch Provider:
-
On the "EMP" screen in Meevo:
- Check to make sure they have the Employee Category “Stretch Therapist”.
- Verify they have the Security Role of “Service Provider”.
-
Make sure the services they can perform have been enabled.
- Verify that they have STR30: Stretch 30 Min Session and STR60: Stretch 60 Min Session selected under "Services" as applicable.
- If the stretch provider also offers RTR30: 30-Min Rapid Tension Relief Session, ensure the RTR30 service is set to can perform as well.
- Verify that they have their correct schedule set up in the “Schedules” screen.
-
Make sure they have logged into the iPads at least once.
- Stretch Therapists don’t complete Modality Survey, so logging into the Appointment Notes App will create their Engage profile.
Additional Information:
If you have completed all the steps above, and are still having issues, create a ticket with the steps you have taken and a screenshot of any errors you received when attempting these steps. Also be sure to include the name of the Therapist or Esthetician that is having the issue.