Enabling Trust Mode
Issue/Symptoms:
Receipt Printer doesn’t print
Applies to:
Star TSP 650II
Cause:
Google Chrome update caused issue of blocking printing
Prerequisites:
Meevo Manager level access or above
Workaround:
1. Clear the cache and cookies in Chrome(on each computer), using the browser’s Settings menu. Click the three vertical dots icon in the top-right corner of the screen, hovering over “More Tools,” and then selecting “Clear Browsing Data”
2. You should now be at the “Clear Browsing Data” window. Click the arrow in the box next to “Time Range” to expand the menu and then select "All time"
3. Next, check the boxes next to “Cookies And Other Site Data” and “Cached Images And Files.” Once the boxes are checked, select the “Clear Data” button(after a few moments, your cache and cookies will be cleared)
4. On each counter, activate the POS Station for that computer in POS Hardware>POS Stations. For instance, if Counter 3 trying to print receipts on the Counter 2 receipt printer, you'd need to go in and Activate the POS for Counter3(as shown below). You can also follow the Meevo WalkME titled: “Activate POS”
5. After the POS has been activated close all Google Chrome browsers windows (and all tabs) in order to save the settings
6. Login to Meevo and click on Meevo
7. Click on Register
8. Click on POS Hardware
9. Click Edit in the lower right of window
10. For every receipt printer listed under the tab "Receipt Printer" enable the check box "Use Trust Mode" NOTE: If trust mode is already enabled take the setting off and click "save", then re-enable the setting and save again
11. Click Save
12. Reboot every computer that prints receipts
13. Log back in to Meevo
14. Click on Meevo
15. Click on Register
16. Click on Transaction Editor
17. Click the printer icon on any transaction
''
18. Click Receipt
19. You may receive the following message. If you do receive this message, click the Trust Icon. If you do not, skip to step #22. NOTE: This will need to be done on each station that prints receipts
20. A new browser window will open, you might receive the following message. If you do receive this message, click on Advanced If you do not, skip to step #22
21. Click on "Proceed to 10.xx.xx.xx (unsafe)", do not be concerned with the numbers as these change for each location and for your receipt printers
22. You should then receive the following screen, which you can close the tab once it opens
Additional Information:
When printing in Meevo you will get a message once you print a receipt that your webpage is "Not Secure" this is normal and does not mean that you have a security risk on the computer. This only means that the communication between the computer and the receipt printer is not secure.